آموزش ساخت ربات تلگرام با php آموزش html و css آموزش php آموزش سئو وردپرس آموزش امنیت وردپرس آموزش وردپرس آموزش فرم ساز RSform آموزش سئو جوملا آموزش فروشگاه ساز Hikashop آموزش فروشگاه ساز ویرچومارت آموزش طراحی سایت آگهی تبلیغاتی آموزش امنیت جوملا آموزش طراحی سایت فروش فایل آموزش طراحی قالب ریسپانسیو با Helix آموزش جوملا 3 آموزش ساخت ربات دکمه ی شیشه ای آموزش ساخت ربات همکاری در فروش آموزش ساخت ربات جذب ممبر آموزش ساخت ربات ضد اسپم آموزش ساخت ربات پیوست فایل
yazditabar

مشکل ارور memory size و همچنین ناسازگاری هاست با تابع ini_set

29 پست در این موضوع

سلام

هاستم رو بدلیل اینکه اررور زیر رو میداد تغییر دادم:

Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 128 bytes) in /home/--------/public_html/libraries/joomla/database/database/mysql.php on line 462

*** حالا بعد از انتقال جوملا نه تنها اررور بالایی حذف نشد، بلکه ارورهای زیر هم نمایش داده میشه و سایت بالا نمیاد!

Warning: ini_set() has been disabled for security reasons in /home/---/public_html/libraries/joomla/session/session.php on line 102

Warning: ini_set() has been disabled for security reasons in /home/---/public_html/libraries/joomla/session/session.php on line 105

Warning: ini_set() has been disabled for security reasons in /home/---/public_html/libraries/joomla/session/session.php on line 655

Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /home/---/public_html/libraries/joomla/session/session.php:102) in/home/---/public_html/libraries/joomla/session/session.php on line 423

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/---/public_html/libraries/joomla/session/session.php:102) in/home/----/public_html/libraries/joomla/session/session.php on line 423

Warning: Cannot modify header information - headers already sent by (output started at /home/---/public_html/libraries/joomla/session/session.php:102) in/home/---/public_html/libraries/joomla/session/session.php on line 426

Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 128 bytes) in /home/---/public_html/libraries/joomla/database/database/mysql.php on line 462

لطفا راهنمایی کنین!

-------------------------------------------------

.:عنوان تاپیک بعلت نامناسب بودن تغییر یافت:.

ویرایش شده در توسط Vahid Taheri
تغییر عنوان

Share this post


Link to post
Share on other sites

دیتا بیس را ریپیر کنید درست میشه

نشد تماس خصوصی بگیرید تا هاست از شرکت ما بگیرید

شاد باشید

Share this post


Link to post
Share on other sites
دیتا بیس را ریپیر کنید درست میشه

دقیقا میشه بفرمایی کجای این ارور ، کوچکترین دخلی به دیتابیس پیدا میکنه؛ جناب!؟؟؟؟!!!؟؟؟

نشد تماس خصوصی بگیرید تا هاست از شرکت ما بگیرید

واقعا لذت بردم از این پاسخگویی کاملا سودجویانه تون!!! خوشحالم که معلوم شد ؛ ارتباط اون ارور و مشکل به دیتابیس چی بود!!!

با وجود اینکه این کاربر گفته مشکل داشته تازه هاست خودش رو عوض کرده؛ بازم شما جای ارائه راه حل، میخوای یک ضرر الکی و بی مورد دیگه ای بهشون بزنی!

به مدت 1هفته از انجمن اخراج شده اید/

--------------------------

دوست عزیز برای رفع مشکل هاست اولیه و فعلی تون متن زیر رو مطالعه کنید

برای اینکار دو روش موجود است.

[h=2][/h] اولین روش این است که php.ini آپاچی را یافت کرده و سپس ویرایش کنید.

حال بدنبال متن زیر باشید:

memory_limit جلوی این متن مقداری مثلا برابر با ۱۶ شاید باشد.بایستی این مقدار را به رقم بالاتری تغییر دهید.مثلا ۶۴ و شاید هم بیشتر.

در صورتی که ۶۴ کنید به این شکل خواهد شد.

memory_limit = 64M سپس فایل را ذخیره و آپاچی ( وب سرور ) را مجدد بارگزاری ( RESET ) کنید.

[h=2]از طریق .htaccess[/h] روش دوم استفاده از .htaccess می باشد.

برای اینکار فایل .htaccess موجود در وب سایت خود ( پوشه ای که جوملا نصب است) و پوشه مدیریت را ویرایش کنید (*در صورتی که این فایل وجود ندارد بسازید و سپس ویرایش کنید )

حال در این فایل کد زیر را قرار دهید.

php_value memory_limit 64M جومفا

برای مابقی ارورها هم تابع ini_set روی سرورتون غیرفعاله به مدیر سرور بگید تا فعال کنه و اگر نکرد مثل روش بالا میتونید خودتون داخل فایل php.ini تعریف و مدیریت کنید(فعال/غیرفعال) این تابع رو.

موفق و سربلند و پایدار باشید

یا حق

Share this post


Link to post
Share on other sites

مرسی..

فقط ارور زیر مونده:

Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 79 bytes) in /home/---/public_html/libraries/joomla/database/database/mysql.php on line 462

** php.ini آپاچی رو که گفتین در فایل منجیر سرچ کردم پیداش نکرد!

** درون فایل .htaccess هم وقتی عبارت php_value memory_limit 64M جومفا رو قرار میدم سایت کلا بالا نمیاد

لطفا کل کدهایی که باید تووی فایل .htaccess قرار بگیره رو بهم بگین یا فایل صحیح .htaccess رو برام attash کنین

سپاس

Share this post


Link to post
Share on other sites

سلام علیکم.دوست عزیز

فایل ادیت شده برای هر دو نسخه ی جوملا رو گذاشتم.

شما اگر مشکلتون برطرف نشد.فایل رو باز کنید و مقدار 64مگ رو بالا ببرید تا جایی که ارور رفع شه....

موفق باشید و سربلند

Share this post


Link to post
Share on other sites

سلام

درست نشد / ارور Internal Server Error میده

ممنون میشم بررسی کنین

اطلاعات رو بصورت پیام خصوصی ارسال کردم

Share this post


Link to post
Share on other sites

آقای مردانه زاده یک سوال دلیل اصلی خطای Fatal error: Allowed memory size چیه؟چیزی که زیاد دیدم اما دلیل اصلیشو نفهمیدم به چه علتی این مشکل ایجاد میشه؟و اینکه بعضی شرکت ارائه دهنده هاست محدودیت دارن و حداکثر memory_limit 256M ارائه میدن در این صورت این مشکل چطوری رفع میشه؟

Share this post


Link to post
Share on other sites

علتش همون عددی هست که بعنوان حجم قرار میگیره :memory_limit 256M

و اینکه اندازه فایل از این سایز بزرگتر هست

این مورد در تنظیمات php.ini ست میشه

Share this post


Link to post
Share on other sites

سلام مجدد

بعد از یه مدت، مجددا با این مشکل مواجه شدم و 2تا از سایت هام اررور زیر رو میدن!!!

Allowed memory size of 67108864 bytes exhausted

لطفا اگر کسی میرسه اطلاعات رو بهش بدم تا بررسی کنه

ممنون

Share this post


Link to post
Share on other sites

ابتدای تاپیک گفته شده چیکار بکنید همون کارها رو انجام بدید درست میشه

Share this post


Link to post
Share on other sites

برای اینکار دو روش موجود است.

[h=2][/h] اولین روش این است که php.ini آپاچی را یافت کرده و سپس ویرایش کنید.

حال بدنبال متن زیر باشید:

memory_limit جلوی این متن مقداری مثلا برابر با ۱۶ شاید باشد.بایستی این مقدار را به رقم بالاتری تغییر دهید.مثلا ۶۴ و شاید هم بیشتر.

در صورتی که ۶۴ کنید به این شکل خواهد شد.

memory_limit = 64M سپس فایل را ذخیره و آپاچی ( وب سرور ) را مجدد بارگزاری ( RESET ) کنید.

[h=2]از طریق .htaccess[/h] روش دوم استفاده از .htaccess می باشد.

برای اینکار فایل .htaccess موجود در وب سایت خود ( پوشه ای که جوملا نصب است) و پوشه مدیریت را ویرایش کنید (*در صورتی که این فایل وجود ندارد بسازید و سپس ویرایش کنید )

حال در این فایل کد زیر را قرار دهید.

php_value memory_limit 64M جومفا

1- فایل php.ini رو پیدا نمیکنم

2- فایل htaccess رو ادیت میکنم، کلا سایت از دسترس خارج میشه

اگه دوستی میرسه چک کنه اطلاعات رو بهش بدم

ممنون

Share this post


Link to post
Share on other sites

ّهتره به مدیریت هاست بگین این مشکل رو برطرف کنن به خاطر نسخه پی اچ پی است که بهتره خود مدیر هاست مقادیر رو افزایش بده بهتره شاید دسترسی از مدیریت بسته شده باشه

Share this post


Link to post
Share on other sites
1- فایل php.ini رو پیدا نمیکنم

2- فایل htaccess رو ادیت میکنم، کلا سایت از دسترس خارج میشه

اگه دوستی میرسه چک کنه اطلاعات رو بهش بدم

ممنون

شما به فایل php.ini دسترسی ندارید باید یک فایل php.ini بسازید و در سایتتون آپلود کنید

Share this post


Link to post
Share on other sites

با سلام

فایل htaccess رو براتون ادیت کردم و اسمش رو عوض کردم و مقدار مموریش رو هم بروی 256مگ قرار دادم.فایل پیوست شده رو دانولد کتید و روی هاستتون آپ کنید.(از حالت فشرده خارج کنید) دیگه به چیزی دست نزنید و تغییرش ندید.

یا اینکه کدی که در زیر اورده شده روداخل یک فایل htaccess قرار بدید و ....

##
# @version $Id: htaccess.txt 21064 2011-04-03 22:12:19Z dextercowley $
# @package Joomla
# @copyright Copyright (C) 2005 - 2010 Open Source Matters. All rights reserved.
# @license http://www.gnu.org/copyleft/gpl.html GNU/GPL
# Joomla! is Free Software
##


#####################################################
#  READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE
#
# The line just below this section: 'Options +FollowSymLinks' may cause problems
# with some server configurations.  It is required for use of mod_rewrite, but may already
# be set by your server administrator in a way that dissallows changing it in
# your .htaccess file.  If using it causes your server to error out, comment it out (add # to
# beginning of line), reload your site in your browser and test your sef url's.  If they work,
# it has been set by your server administrator and you do not need it set here.
#
#####################################################

##  Can be commented out if causes errors, see notes above.
#Options +FollowSymLinks

#
#  mod_rewrite in use

RewriteEngine On

########## Begin - Rewrite rules to block out some common exploits
## If you experience problems on your site block out the operations listed below
## This attempts to block the most common type of exploit `attempts` to Joomla!
#
## Deny access to extension xml files (uncomment out to activate)
#<Files ~ "\.xml$">
#Order allow,deny
#Deny from all
#Satisfy all
#</Files>
## End of deny access to extension xml files
# Block out any script trying to set a mosConfig value through the URL
RewriteCond %{QUERY_STRING} mosConfig_[a-zA-Z_]{1,21}(=|\%3D) [OR]
# Block out any script trying to base64_encode data within the URL
RewriteCond %{QUERY_STRING} base64_encode[^(]*\([^)]*\) [OR]
# Block out any script that includes a <script> tag in URL
RewriteCond %{QUERY_STRING} (<|%3C)([^s]*s)+cript.*(>|%3E) [NC,OR]
# Block out any script trying to set a PHP GLOBALS variable via URL
RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
# Block out any script trying to modify a _REQUEST variable via URL
RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
# Return 403 Forbidden header and show the content of the root homepage
RewriteRule .* index.php [F]
#
########## End - Rewrite rules to block out some common exploits


########## Begin - Custom redirects
#
# If you need to redirect some pages, or set a canonical non-www to
# www redirect (or vice versa), place that code here. Ensure those
# redirects use the correct RewriteRule syntax and the [R=301,L] flags.
#
########## End - Custom redirects


#  Uncomment following line if your webserver's URL
#  is not directly related to physical file paths.
#  Update Your Joomla! Directory (just / for root)

# RewriteBase /


########## Begin - Joomla! core SEF Section
#
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
#
# If the requested path and file is not /index.php and the request
# has not already been internally rewritten to the index.php script
RewriteCond %{REQUEST_URI} !^/index\.php
# and the request is for root, or for an extensionless URL, or the
# requested URL ends with one of the listed extensions
RewriteCond %{REQUEST_URI} (/[^.]*|\.(php|html?|feed|pdf|raw))$ [NC]
# and the requested path and file doesn't directly match a physical file
RewriteCond %{REQUEST_FILENAME} !-f
# and the requested path and file doesn't directly match a physical folder
RewriteCond %{REQUEST_FILENAME} !-d
# internally rewrite the request to the index.php script
RewriteRule .* index.php [L]
#
########## End - Joomla! core SEF Section
php_value memory_limit 256M

ضمناً این فایل و کدها برای جوملا 1.5هست...

موفق باشید و سربلند و پایدار

Share this post


Link to post
Share on other sites
دقیقا میشه بفرمایی کجای این ارور ، کوچکترین دخلی به دیتابیس پیدا میکنه؛ جناب!؟؟؟؟!!!؟؟؟

واقعا لذت بردم از این پاسخگویی کاملا سودجویانه تون!!! خوشحالم که معلوم شد ؛ ارتباط اون ارور و مشکل به دیتابیس چی بود!!!

با وجود اینکه این کاربر گفته مشکل داشته تازه هاست خودش رو عوض کرده؛ بازم شما جای ارائه راه حل، میخوای یک ضرر الکی و بی مورد دیگه ای بهشون بزنی!

به مدت 1هفته از انجمن اخراج شده اید/

--------------------------

دوست عزیز برای رفع مشکل هاست اولیه و فعلی تون متن زیر رو مطالعه کنید

برای اینکار دو روش موجود است.

[h=2][/h] اولین روش این است که php.ini آپاچی را یافت کرده و سپس ویرایش کنید.

حال بدنبال متن زیر باشید:

memory_limit جلوی این متن مقداری مثلا برابر با ۱۶ شاید باشد.بایستی این مقدار را به رقم بالاتری تغییر دهید.مثلا ۶۴ و شاید هم بیشتر.

در صورتی که ۶۴ کنید به این شکل خواهد شد.

memory_limit = 64M سپس فایل را ذخیره و آپاچی ( وب سرور ) را مجدد بارگزاری ( RESET ) کنید.

[h=2]از طریق .htaccess[/h] روش دوم استفاده از .htaccess می باشد.

برای اینکار فایل .htaccess موجود در وب سایت خود ( پوشه ای که جوملا نصب است) و پوشه مدیریت را ویرایش کنید (*در صورتی که این فایل وجود ندارد بسازید و سپس ویرایش کنید )

حال در این فایل کد زیر را قرار دهید.

php_value memory_limit 64M جومفا

برای مابقی ارورها هم تابع ini_set روی سرورتون غیرفعاله به مدیر سرور بگید تا فعال کنه و اگر نکرد مثل روش بالا میتونید خودتون داخل فایل php.ini تعریف و مدیریت کنید(فعال/غیرفعال) این تابع رو.

موفق و سربلند و پایدار باشید

یا حق

سلام...

من در لوکالم دچار این مشکل شدم و مسیر فایل php.ini رو پیدا نمیکنم .... میشه راهنمایی کنید؟؟

Share this post


Link to post
Share on other sites

باسلام

اگر روی سیستمتون زمپ نصب کردید.به مسیر برید

C:\xampp\php\php.ini

و توی خط 460 این

memory_limit = 128M

تابع رو ادیت کنید(مقدارش رو بالا ببرید)

موفق باشید و سربلند

Share this post


Link to post
Share on other sites
باسلام

اگر روی سیستمتون زمپ نصب کردید.به مسیر برید

C:\xampp\php\php.ini

و توی خط 460 این

memory_limit = 128M

تابع رو ادیت کنید(مقدارش رو بالا ببرید)

موفق باشید و سربلند

این مقدار باید حتما مضربی از باشه؟؟

من به 512 و 1024 تغییرش دادم ولی درست نشد...

Share this post


Link to post
Share on other sites
بیشترش کنید...

ماکزیمم مقداری که میتونه بگیره چقدر هست؟؟

به من این ارور رو میده ، از روی این میشه فهمید چقدر باید اضافه کرد؟؟

Fatal error: Allowed memory size of 536870912 bytes exhausted (tried to allocate 40961 bytes) in C:\xampp\htdocs\proje2\libraries\joomla\application\module\helper.php on line 174

Share this post


Link to post
Share on other sites

من هرکاری میکنم ارورم روی لوکال برطرف نمیشه...کسی راهنماییم نمیکنه؟؟؟؟ :(

Share this post


Link to post
Share on other sites
ماکزیمم مقداری که میتونه بگیره چقدر هست؟؟

به من این ارور رو میده ، از روی این میشه فهمید چقدر باید اضافه کرد؟؟

Fatal error: Allowed memory size of 536870912 bytes exhausted (tried to allocate 40961 bytes) in C:\xampp\htdocs\proje2\libraries\joomla\application\module\helper.php on line 174

شما به 600 تغییر بدید

من هرکاری میکنم ارورم روی لوکال برطرف نمیشه...کسی راهنماییم نمیکنه؟؟؟؟ :(

کش تون رو پاک کنید و مقدار رو زیاد کنید

Share this post


Link to post
Share on other sites

یکی از دوستان پرسیده بود دلیل اصلی وقوع این ارور چیه؟ این سوال من هم هست. البته پیداست بنا به محدودیتی که ظاهرا مربوط به جداول دیتابیس است باعث وقوع این ارور میشه.

در سایتهای خبری که روزانه مطالب زیادی وارد میشه طبیعیه که بعد از مدتی حجم جدول مطالب بالا میره و اگر درست دلیل ایجاد این ارور رو فهمیده باشم پس بعد از مدتی باید این ارور اتفاق بیفته که با بالا بردن این محدودیت موقتا مشکل حل میشه(که برای من قبلا پیش اومده بود و از هاستینگم خواستم و این مقدار محدودیت رو افزایش داد اما در آینده چی؟

آیا راهی هست که این اتفاق دیگه نیفته با اضافه شدن حجم جدول؟ نمیشه که مطالب رو پاک کرد. من واقعا توی فکر این موضوع هستم که میدونم بزودی واسم مجددا پیش میاد

Share this post


Link to post
Share on other sites
شما به 600 تغییر بدید

کش تون رو پاک کنید و مقدار رو زیاد کنید

به 600 تغییر دادم ولی درست نشد....

من توی اون خط گفته شده ، این مقدارو به 600 تغییر دادم ، بعد یه بار آپاچی و mysql رو stop کردم و دوباره start کردم.... اینجوری باید درست شه دیگه/؟ چرا برا من نمیشه؟؟

منظورتون از کش چیه؟؟

Share this post


Link to post
Share on other sites

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری