alirezazare

رفع مشکل بهم ریختن فونت مدیریت در آپدیت به 3.7

19 پست در این موضوع

با سلام

در بعضی از بسته های جوملا بعد از بروز رسانی آنها به نسخه 3.7 فایل زبان مدیریت فراخوان نشده و موجب بهم ریختگی در صفحه مدیریت می شود

برای رفع این مشکل در محل نصب جوملا مسیر زیر را دنبال کنید

libraries/joomla/language/language.php

در خط 834 کدهای زیر را وارد کنید

            $contents = file_get_contents($filename);
            $contents = str_replace('_QQ_', '"\""', $contents);
            $strings = @parse_ini_string($contents);

 

فایل را ذخیره و صفحه مدیریت را رفرش نمائید.

 

 

5 کاربر پسند شده

Share this post


Link to post
Share on other sites

سلام ببخشید من اپدیت که کردم به 3.7 کل صفحه مدیریت به شکل 

MOD_LOGGED_TITLE

یا امثال این در اومده لطفا کمکم کنید

 

Share this post


Link to post
Share on other sites
در 47 دقیقه قبل، mr.demo گفته است :

سلام ببخشید من اپدیت که کردم به 3.7 کل صفحه مدیریت به شکل 

MOD_LOGGED_TITLE

یا امثال این در اومده لطفا کمکم کنید

 

با سلام

طبق راهنمایی که در بالا گفته شده عمل کنید....

موفق باشید و سربلند

Share this post


Link to post
Share on other sites

خب الان مشکل من اینه که چطور به این قسمت  libraries/joomla/language/language.php برم؟؟؟

حتی من عیب یابی رو هم فعال کردم دوباره درست نشد اگه میشه بگید چطوری به این قسمت برم

Share this post


Link to post
Share on other sites

شما باید وارد هاستتون بشید و در روتی که فایلهای جوملا قرار داره مسیر زیر را برید

Share this post


Link to post
Share on other sites

سلام دوستان ماله من دوباره به هم ریخت حالا دیگه اصلا نه سایت میاد بالا نه صفحه مدیریت جوملا لطفا کمک کنید

Share this post


Link to post
Share on other sites

با سلام

قالب مدیریت از یک جوملای خام رو بردارید و بروی سایت فعلی تون آپلود کنید.

قبل از انجام هر تغییری بکاپ گیری فراموش نشود.

اگر هم مایل هستید میتونید لینک سایت رو ارسال کنید تا بررسی بشه

موفق باشید و سربلند

Share this post


Link to post
Share on other sites

اقای مردانه زاده مدونی چی شد من بعد از اینکه مشکل فونتم حل شد اپدیت 3.7.1 اومد اپدیت کردم دوباره بهم ریخت و دیگه درست نشد با راه حل بالا رفتم تو قسمت اپدیت داخل همون صفحه مدیریت به صورت دستی فایل نسخه 3.6.5 رو بهش دادم گفتم شاید برگرده نسخه قبل و درست بشه که دیگه نیامد بالا داخل سی پنل رفتم و فایل جوملا رو دوباره اکسترکت کردم و بعد اومدم تو صفحه مدیریت دیدم نوشته نصب با موفقیت انجام شد و باید پوشه installation حذف بشه من زدم حذف شد و دیگه از کار افتاد الان این جوری شد لطفا بگید چیکار کنم

اینم ادرس سایت www.zigoratdesigner.ir

Share this post


Link to post
Share on other sites
در در 5/6/2017 در 14:23، alirezazare گفته است :

با سلام

در بعضی از بسته های جوملا بعد از بروز رسانی آنها به نسخه 3.7 فایل زبان مدیریت فراخوان نشده و موجب بهم ریختگی در صفحه مدیریت می شود

برای رفع این مشکل در محل نصب جوملا مسیر زیر را دنبال کنید

libraries/joomla/language/language.php

در خط 834 کدهای زیر را وارد کنید


            $contents = file_get_contents($filename);
            $contents = str_replace('_QQ_', '"\""', $contents);
            $strings = @parse_ini_string($contents);

 

فایل را ذخیره و صفحه مدیریت را رفرش نمائید.

 

 

سلام

جناب زارع عزیز بنده هم این مشکل رو دارم ، به آدرسی که فرمودید مراجعه کردم کدی که شما ارسال فرمودید الانم روی این فایل هستش !

اما بنده همچنان این مشکل رو دارم

Share this post


Link to post
Share on other sites
در 6 دقیقه قبل، avatararea گفته است :

سلام

جناب زارع عزیز بنده هم این مشکل رو دارم ، به آدرسی که فرمودید مراجعه کردم کدی که شما ارسال فرمودید الانم روی این فایل هستش !

اما بنده همچنان این مشکل رو دارم

با سلام

دسترسی هاست و ادمین جوملا را پیام خصوصی کنید

Share this post


Link to post
Share on other sites

من در نسخه 3.7.2 هم با این مشکل روبرو شدم و کد رو قرار دادم در قسمت مربوطه ولی بازم مشکل هست

Share this post


Link to post
Share on other sites

سلام لطفا کمک کنید در ورژن 3.7.2 این مشکل هست و کد رو هم وارد کردم باز هم فونت سایت دارای مشکله ؟؟؟؟

این کدی هست که قرار دادم :
 

		if (!function_exists('parse_ini_file'))
		{
			$contents = file_get_contents($filename);
			$contents = str_replace('_QQ_', '"\""', $contents);
			$strings = @parse_ini_string($contents);
		}

 

Share this post


Link to post
Share on other sites

مشکل رفع شد : جواب :
لطفا در فایل language.php از خط 833 تا 850 را پاک کنید و بعد کد زیر را در خط 833 قرار دهید تا مشکل رفع گردد :
 

		$strings = @parse_ini_file($filename);
        $contents = file_get_contents($filename);
		$contents = str_replace('_QQ_', '"\""', $contents);
		$strings = @parse_ini_string($contents);

 

1 کاربر پسند دیده است

Share this post


Link to post
Share on other sites

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری