me64

مشکل با افزونه BT-Content slider در مرورگر کروم

14 پست در این موضوع

ارسال شده در (ویرایش شده)

سلام

از ماژول BT-Content slider در سایتم دارم استفاده میکنم

مشکلی که دارم اینه که در مرورگر گوگل کروم وقتی صفحه مرورگر در زمان لود صفحه به هر اندازه ای باشه ماژول مطلب رو نمایش میدهد ولی وقتی سایز صفحه مرورگر رو تغییر میدهم دیگر محتویات ماژول نمایش داده نمیشود

مثلا وقتی مرورگر گوگل کروم در زمان لود سایت به صورت فول سایز (maximize) باشه مشکلی ندارم ولی وقتی سایز مرورگر رو تغییر بدم دیگه محتویات ماژول ناپدید میشوند(برعکس این حالت هم اتفاق میافته وقتی سایز مرورگر کوچیک باشه و کاربر اون رو full size کنه یا اصلا به صورت دستی سایز مرورگر رو تغییر دهد)

در لینک زیر میتوانید دمو را در انتهای صفحه ببینید

دموی آنلاین

ویرایش شده در توسط mmfallah

Share this post


Link to post
Share on other sites


این ایراد از کدهای css هست که به پوزیشن دادید و همخوانی با مرورگر کروم ندارد . باز هم برای اطمینان قالب پیش فرض را عوض کنید و این ماژول را در آن منتشر کنید و ببینید نتیجه چیست

Share this post


Link to post
Share on other sites

این کدی است که برای این موقعیت نوشتم نمیدونم کدوم بخشش میتونه مشکل ساز باشه

#mashahir{
height:auto;
width:980px;
border-radius:5px;
background-color:#CCC;	
clear:both;
margin-top:15px;
margin-right:10px;
}

Share this post


Link to post
Share on other sites

حذف کردم همچنان همون مشکل وجود داره

height:206px; رو هم الان دادم که به صورت auto نباشه که بازم حل نشده.

Share this post


Link to post
Share on other sites
حذف کردم همچنان همون مشکل وجود داره

height:206px; رو هم الان دادم که به صورت auto نباشه که بازم حل نشده.

دوست عزیز اون auto رو برگردونید به حالت اولیش دوباره بنویسید. کد رو به این شکل در بیارید :

#mashahir{ 	height:auto; 	width:auto; 	border-radius:5px; 	background-color:#CCC;	 	clear:both; 	margin-top:15px; 	margin-right:10px;

Share this post


Link to post
Share on other sites
دوست عزیز اون auto رو برگردونید به حالت اولیش دوباره بنویسید. کد رو به این شکل در بیارید :

#mashahir{     height:auto;     width:auto;     border-radius:5px;     background-color:#CCC;         clear:both;     margin-top:15px;     margin-right:10px;

height:auto;

width:auto;

باید طول و عرضتون auto باشه تا تو هر اندازه ای خودش اندازش رو ست کنه . امیدوارم با انجام اینکار مشکلتون حل بشه

Share this post


Link to post
Share on other sites

حذف نمیشه . میره 2000 پیکسل به راست . از پنجره خارج میشه . حالا کدش از کجا ریشه میگیره رو باید پیدا کنید .

این کد رو به انتهای template.css اضافه و تست کنید :)

[font=Verdana].slides_control[/font]{width: 100%!important;
left:0px!important;
[font=Verdana]}[/font]

Share this post


Link to post
Share on other sites

کدش رو هم اگه خواستید پیدا کنید اینه . توی ایندکس ماژول فکر کنم باید باشه .

[font=Verdana]<div class="slides_control" style="direction: rtl; [color=#ff0000][b]left: -980px; width: 2940px;[/b][/color] height: 171px;"><div class="slide" style="width: 980px; left: 980px;">[/font]					[font=Verdana]

[/font]

Share this post


Link to post
Share on other sites

متشکرم از همه دوستان

با اضافه کردت کد زیر به فایل css حل شد

div.slides_control {

   width:100% !important;

}

Share this post


Link to post
Share on other sites

سلام.

میشه خواهش کنم بگید دقیقا کد width:100% !important; را به کدام css اضافه کردید؟؟

منم دقیقا همین مشکلو دارم. (وقتی صفحه کوچیک میشه و یا در گوشی دیگه ماژولو نمیبنیم)

خواهش میکنم راهنمایی کنید

با سپاس فراوان

Share this post


Link to post
Share on other sites

فرق نمیکنه . به یکی از فایل ها که در صفحه لود شده اضافه کنید. مثلا template.css

و اینکه دستور رو کامل ادد کنید. به همراه کلاس

Share this post


Link to post
Share on other sites

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری