danial2014

خطای مسیر امن در ویرچومارت

11 پست در این موضوع

با سلام خواهش میکنم کمک کنید

هر کاری میکنم این اررور نمیره

هر جا بگید این آدرس رو ساختم پوششو اما فایده نداره

اخطار, این مسیر امن هست غیر قابل دسترس (وجود ندارد یا مجوز دسترسی ندارد), به به دلایل ایمنی ایجاد یک پوشه در یک مسیر غیر قابل دسترس توسط URL بسیار مهم است, همچنین ایجاد پوشه فاکتورها برای ذخیره داده های حساس و امن خود در آن. راه پیشنهادی ما برای سیستم شما /home/xxx/vmfiles, با استفاده از این لینک به config

ممنون

Share this post


Link to post
Share on other sites

با سلامی مجدد با چنتا سرچ انگلیسی مورد رو پیدا کردم و مشکلم حل شد در این مشکل اصلا تا به حال در مورد وب های فارسی صحبت نشده بود

برای حل مشکل به لینک زیر مراجعه کنید راحت حل میشه

How to fix Safe Path is empty error in VirtueMart? - Tips & How to - Joomla Templates and WordPress Themes - Gavick.com Blog

Share this post


Link to post
Share on other sites
با سلامی مجدد با چنتا سرچ انگلیسی مورد رو پیدا کردم و مشکلم حل شد در این مشکل اصلا تا به حال در مورد وب های فارسی صحبت نشده بود

برای حل مشکل به لینک زیر مراجعه کنید راحت حل میشه

How to fix Safe Path is empty error in VirtueMart? - Tips & How to - Joomla Templates and WordPress Themes - Gavick.com Blog

با سلام منم همین مشکل رو دارم ولی سایتی که معرفی کردی باز نمیشه کسی نیست بتونه راهنمایی بکنه باید چیکار کنم

Share this post


Link to post
Share on other sites

معمولا این مشکل وقتی پیش میاد که تنظیمات ویرچومارت کامل انجام نشده باشه!

بعد ایجاد محصول اگر که تنظیمات قبلا انجام نشده باشه این خطا رو میده که باید به لینکه که بالای صفحه برای ایجاد مسیر امن میده برید و تمام فیلد هارو کامل کنید وگرنه پوشه ایجاد نمیشه و دوباره همین خطارو میده.

من که قبلا این مشکل رو داشتم ،اینجوری حل شده...

Share this post


Link to post
Share on other sites

روشی هم که دوستمون گفتن این هست که.

تو روت جوملا داخل فولدر log یه فولدر جدید ایجاد کنید

از قسمت مدیریت جوملا وارد بخش Configuration -> System. بشید

مسیر اون فولدری که داخل فولدر log ساخته بودید رو کپی کنید

و قسمت تنظیمات ویرچومارت وارد بخش Configuration -> Templates.بشید

و نهایتا قسمت media files setting مقدار safe path یا مسیر امن رو بعد از www/مسیر فولدر ساخته شده داخل فولدر log که قبلا هم کپی کرده بودید قرار بدین.

Share this post


Link to post
Share on other sites

ارسال شده در (ویرایش شده)

روشی هم که دوستمون گفتن این هست که.

تو روت جوملا داخل فولدر log یه فولدر جدید ایجاد کنید

از قسمت مدیریت جوملا وارد بخش Configuration -> System. بشید

مسیر اون فولدری که داخل فولدر log ساخته بودید رو کپی کنید

و قسمت تنظیمات ویرچومارت وارد بخش Configuration -> Templates.بشید

و نهایتا قسمت media files setting مقدار safe path یا مسیر امن رو بعد از www/مسیر فولدر ساخته شده داخل فولدر log که قبلا هم کپی کرده بودید قرار بدین.

من این کارم انجام دادم اما بازم ارور میده

اخطار, این مسیر امن هست غیر قابل دسترس (وجود ندارد یا مجوز دسترسی ندارد), به به دلایل ایمنی ایجاد یک پوشه در یک مسیر غیر قابل دسترس توسط URL بسیار مهم است, همچنین ایجاد پوشه فاکتورها برای ذخیره داده های حساس و امن خود در آن. راه پیشنهادی ما برای سیستم شما /home/***/public_html/vmfiles, با استفاده از این لینک به config

03434320328201055361.jpg

ویرایش شده در توسط masood30
eshtebah

Share this post


Link to post
Share on other sites

سلام دوستان برای حل این مشکل باید یه پوشه به نام extra-safe داخل C:\wamp\www\****\logs بسازید بعد همین ادرسو

C:\wamp\www\****\logs\extra-safe برید داخل پیکربندی بعد برید قسمت قالب ها بعد مسیر امن همین ادرسو کپی کنید و ذخیررو بزنید

مشکل حل میشه

موفق باشید

Share this post


Link to post
Share on other sites

سلام دوستان و روز همگی بخیر.من هم این مشکل دارم و با راه حل های ارائه شده پیش رفتم و جواب نگرفتم.بنده مبتدی هستم و به صورت لوکال کار می کنم.لطف می کنید راهنمایی بفرمایید؟

 

 

Share this post


Link to post
Share on other sites

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری